Proxy_set_header Upgrade $http_upgrade

I added the following lines to Nginx config in the reverse proxy area:

proxy_set_header Upgrade $http_upgrade
proxy_set_header Connection 'upgrade';

and in Uvicorn 0.11.8, everything are ok.
but after upgraded to 0.12.2, all request shows a warning message: WARNING: Unsupported upgrade request.

I did not even do any http upgrade.